【通达信】秒杀一切顶底指标 简单明了优化

2016.07.28 23:25

gainianba-ad

2016-7-28 23-26-42

 

{1.主进红柱、洗盘绿柱}
VR2:=REF(LOW,1);
VR3:=SMA(ABS(LOW-VR2),3,1)/SMA(MAX(LOW-VR2,0),3,1)*100;
VR4:=EMA(IF(CLOSE*1.3,VR3*10,VR3/10),3);
VR5:=LLV(LOW,30);
VR6:=HHV(VR4,30);
VR7:=IF(MA(CLOSE,58),1,0);
主力:=EMA(IF(LOW<=VR5,(VR4+VR6*2)/2,0),3)/618*VR7,COLORMAGENTA,NODRAW;
VR9:=IF(主力>100,100,主力);
STICKLINE(VR9>0,48,55,2,0),COLORMAGENTA;
STICKLINE(主力<REF(主力,1)OR VR9<REF(VR9,1),43,36,2,0),COLORGREEN;
{2.低吸高抛:强买}
VAR1:=REF(CLOSE,2);
趋势线:SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,LINETHICK2,COLORLIBLUE;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
STICKLINE(趋势线>85,78,85,1.2,0), COLORYELLOW; {逢高派发}
STICKLINE(趋势线>90,78,85,1.8,0), COLORRED; {极高风险}
DRAWICON(趋势线>95 ,100,2);
DRAWICON(VAR3<12,80,38);
DRAWICON(趋势线<12,80,34);
{3.轻仓大底}
长期线:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19)+100,COLOR9900FF,LINETHICK3;
中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100,COLORYELLOW,LINETHICK2;
STICKLINE(中期线<12,20,0,1,0), COLORYELLOW;
STICKLINE(长期线<12,20,0,1,0), COLORRED;
{4.强势拉升}
上趋势:=MA(LOW,20)*1.2,COLOR0080FF,LINETHICK2;
次上趋势:=MA(LOW,20)*1.1,COLORYELLOW;
次下趋势:=MA(HIGH,20)*0.9,COLORWHITE;
下趋势:=MA(HIGH,20)*0.8,COLORGREEN,LINETHICK1;
趋势强度:=IF(C>次上趋势,IF(C>上趋势,4,3),IF(C>次下趋势 AND C<次上趋势,2,IF(C<下趋势,0,1))),NODRAW;
{5.一目了然}
MA多:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100,COLORFFB5FF,LINETHICK2;
多方:EMA(MA多,5),COLORYELLOW,LINETHICK2;
STICKLINE(多方>75,72,65,1.2,0), COLORYELLOW;
STICKLINE(多方>80,72,65,1.2,0), COLORRED;
DRAWICON(多方>85,55,2);
{6.建仓}
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA
(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
DRAWICON(趋势<=3 AND 趋势强度<=1,63,25);
{7.临界点}
C1:=((MA(C,30)-L)/MA(C,60))*200;
临界点:=IF(C1>30,68,45),LINETHICK3,COLORRED;
{8.超级短底}
短底:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+
(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3,NODRAW;
超短:=IF(短底<-10 AND 主力>REF(主力,1),60,12),COLORLIRED,LINETHICK2,NODRAW;
{9.成本线}
VBR1:=IF(DATE>=10201201,0,1);
VBR4:=(2*CLOSE+LOW+HIGH)/4*VBR1;
必卖线:=EMA(VBR4,55)*1.3,COLORRED;
DRAWICON(必卖线,63,35);
{10.三层底}
趋线:(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,COLORAABBDD,NODRAW;
STICKLINE(趋线<-20,16,0,2,0), COLOR6BB03E;
DRAWTEXT(CROSS(-20,趋线),90,’浅底’),COLOR6BB03E;
STICKLINE(趋线<-25,11,0,3,0), COLORD7B756;
DRAWTEXT(CROSS(-25,趋线),80,’深底’),COLORD7B756;
STICKLINE(趋线<-30,6,0,4,0), COLOR965437;
DRAWTEXT(CROSS(-30,趋线),68,’绝底’),COLOR965437;
{11.走势铁底}
M:=88;
VARX1:=EMA(AMOUNT/VOL/100,3);
低吸伏击:=EMA(VARX1,M)*0.85,LINETHICK2,COLORFFFF00;
走势铁底:=低吸伏击*0.87,LINETHICK3,COLORFF00FF;
STICKLINE(L<走势铁底,1.5,0,5,0), COLOR1978E6;
底线:=EMA(VBR4,40)*0.85,COLORWHITE,LINETHICK2;
铁底线:=EMA(VBR4,88)*0.7,COLORRED;
成本线:=EMA(VBR4,55),COLORGREEN,LINETHICK2;
价值中枢:=(成本线+底线)/2,COLORFFFF00;
铁底:IF(C<铁底线 AND 超短,73,25),COLORLIBLUE,LINETHICK3,NODRAW;
大底天数:BARSLAST(CROSS(12,长期线)),NODRAW;
85,POINTDOT,COLORWHITE;
风险:75,COLORGREEN;
强弱:45,DOTLINE,COLORRED,LINETHICK1;
30,COLORLIRED;

由于该指标整合了不少小段,所以难免线条繁杂,不能一看就明了,有不少新朋友问用法。所以就有了对指标优化的冲动:对指标图中的繁杂的线条去掉,用有色柱线和图标替代,简单明了。说明如下:
一、图标:红宝石为建仓;黄、红向上箭头为买入;绿色向下箭头为减仓或逃顶。
二、柱线:
1、在75线以上的柱线:黄色代表逢高派发;绿色代表风险。
2、在75线以下的柱线:黄色代表多方;红色多方占优。
3、在45线以上的柱线:洋红色代表主力进场。
4、在45线以下的柱线:绿色代表洗盘。
5、在0线以上的柱线:黄色代表中期底;红色代表长期底。
6、在0线以上的柱线:蓝色代表绝底;青色代表深底;淡绿色代表浅底;橘黄色代表铁底。
三、图中随机出现的文字对应柱线颜色。

指标不是万能,决策还是靠自己!

1 0 0

东方智慧,投资美学!

我要投稿

申明:本文为作者投稿或转载,在概念股网 http://www.gainiangu.com/ 上发表,为其独立观点。不代表本网立场,不代表本网赞同其观点,亦不对其真实性负责,投资决策请建立在独立思考之上。

< more >

ABCDEFGHIJKLMNOPQRSTUVWXYZ0-9
暂无相关概念股
暂无相关概念股
go top