【通达信】生命与宝塔线主图指标公式

2016.04.14 02:16

gainianba-ad

2016-4-14 18-14-43

VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
STICKLINE((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),CLOSE,REF(CLOSE,1),3,1),COLORRED;
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
STICKLINE((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),CLOSE,REF(CLOSE,1),3,1),COLORFF9900;
VAR1A:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0)COLORYELLOW;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,REF(CLOSE,1),REF(CLOSE,2),4,0)COLORBLUE;
YC_AA:=(O+C)/2;
{看趋势做股,关键是涅磐黄线,信号不需怕多,短线看宝瓶般若,中线看BS及笑脸,};
{长数念珠,灵活运用周期,世间万法皆缘,发财请多行善,有好的人品必能做好股品.};
{弹指能发人于丈外是太极,仅能保健也是太极,未到如火纯青地、莫论太极长与短.};
摩:=(HIGH+4*LOW+OPEN+CLOSE)/7;
诃:= EMA(摩,13) – EMA(摩,34);
波:= EMA(诃,5);
罗:=(诃-波)*5;
柳枝A:=IF(罗>=1000 ,1000 ,IF(罗<=摩,摩,罗) );
甘露:FORCAST(FORCAST(柳枝A,31),10),LINETHICK3,COLORBLUE{短期趋势};
CSAR:=SAR(10,2,20);
持币:=IF(CSAR>=H,CSAR,0),CIRCLEDOT,COLORGREEN{持币};
持股:=IF(CSAR<=L,CSAR,0),CIRCLEDOT,COLORRED{持股};
涅磐:EMA(SLOPE(C,21)*20+C,42),LINETHICK2,COLORRED;{股价在上持,在下空仓}
宝瓶:EMA(C,2.5),COLORGREEN,LINETHICK1;
般若:EMA(C,5),COLORYELLOW,LINETHICK1;{红持股绿持币黄观望}
菩提:=XMA(H,20);{此函数仅做参考线,为提前趋势预测线,上涨途中向下见顶,下跌途中向上见底};
开悟:IF(般若>=REF(般若,1),般若,DRAWNULL),LINETHICK2,COLORRED;{持股前提}
闭关:IF(般若<=REF(般若,1),般若,DRAWNULL);{持币前提}
{DRAWICON(CROSS(CSAR,H) AND L<涅磐 AND 涅磐>菩提 ,HIGH*1.02,6);{趋势顶}
DRAWICON(CROSS(L,CSAR) AND 开悟>0 AND H<菩提 AND 持股>0 AND H>涅磐,(LOW * 0.93),5);{趋势底}
{DRAWICON(CROSS(宝瓶,涅磐) AND H>涅磐 AND 菩提>宝瓶 AND H<菩提,L*0.91,7);}{波段底}
{DRAWICON(CROSS(涅磐,般若) AND 闭关>0 AND 菩提<涅磐, H*1.08,8);}{波段顶}
{www.gainiangu.com 概念股网_通达信股票指标公式}
{DRAWICON(CROSS(般若,宝瓶) AND 涅磐>C AND 闭关>0,H*1.01,2);{上涨不看卖,短线用时打开}
{DRAWICON((CROSS(宝瓶,般若) AND 开悟>0 AND 持股>0 AND C>般若 AND 菩提>涅磐 AND C<菩提 ),(LOW*0.96),1),COLORRED;{下跌不看买,短线突破时打开}
{DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),’◎’),COLORGREEN;{短线调整信号}
{DRAWICON(CROSS(菩提,涅磐),L*0.971,3);{牵引见底标志,股价向下菩提向上}
{DRAWICON(CROSS(涅磐,菩提),H*1.043,9);{牵引见顶标志,股价向上菩提向下}
{STICKLINE(涅磐>=菩提,H,L,0,1),COLORGREEN;{绿心持币}
{STICKLINE(菩提>=涅磐,H,L,0,1),COLORRED;{红心持股}
{VARC:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;}
{DRAWICON(CROSS(77,VARC),HIGH,2);}
{VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;}
{VAR2:=REF(VAR1,5);}
{VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;}
{VAR4:=FILTER(IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);}
{DRAWICON(VAR4,LOW,1);};
般:XMA(CLOSE,7),COLORBROWN;
若:MEMA(CLOSE,3),COLORLIBLUE;{般值大于若值持股,反之空仓}
{柳枝:(般-若)*6.18,COLORSTICK;}{比传统MACD信号提早2-3天,红绿柱为涨跌动量的前瞻标志}
DRAWICON(LONGCROSS(般,若,0.25) AND 菩提>H ,L*0.958,1),COLORRED;{超短线时选择用,扫尽买点}
{DRAWICON(LONGCROSS(若,般,0.25) AND C>涅磐 AND H>菩提,H*1.03,2),COLORGREEN;}{超短线选择用,扫尽卖点}
{关闭的指标开1关1地选择性应用,综合判断(通达信输出限制)其中采用的XMA函数也仅是为了严谨信号的出现而增加的一个附加筛选条件之一,(杜绝马后炮及飘移现象),}
{高手运用此公式玩股于掌心,技术指标应具备前瞻性才能快人一步,08年更需如此才能立足市场,此公式经过了2年实战验证,欢迎市场实战交易者斧正.南无观世音菩萨!};

 

0 0 0

数字时代的手工艺人

我要投稿

申明:本文为作者投稿或转载,在概念股网 http://www.gainiangu.com/ 上发表,为其独立观点。不代表本网立场,不代表本网赞同其观点,亦不对其真实性负责,投资决策请建立在独立思考之上。

< more >

ABCDEFGHIJKLMNOPQRSTUVWXYZ0-9
暂无相关概念股
暂无相关概念股
go top